Cast Iron Collector Forums  
Google

Go Back   Cast Iron Collector Forums > General Discussion > Cast Iron Cleaning and Seasoning

Notices

Cast Iron Cleaning and Seasoning Help With and Tips & Techniques For Cast Iron Cookware Restoration

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-11-2021, 07:30 PM
K_Leonard K_Leonard is offline
Member
 
Join Date: Dec 2020
Posts: 15
Default Electrolysis Tank - Newbie!

I set up my first electrolysis tank yesterday evening and it appears to be working but I'm not sure. I'm using a 20 gallon plastic tub, rebar for the anode, and a newly purchased 12V/6V battery charger. It seems to be working okay; the piece is very rusty. I noticed the battery charger would blink green yesterday and today but after unplugging, disconnecting the positive and negative clamps, and pulling the cast iron piece for inspection this evening that once I tried to set it all back up, the battery charger isn't blinking green. Does that mean it's not working? The surface of the bath is very foamy but I'm not seeing active bubbles coming up. I used OxiClean washing soda and specifically looked for sodium carbonate as the main ingredient (not sodium bicarbonate).
Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Advertisement

- Website Directory -

This site is a participant in the Amazon Services LLC Associates Program,
an affiliate advertising program designed to provide a means for sites to earn
advertising fees by advertising and linking to Amazon.com or its affiliates.
This page contains ads and links that earn commissions for CIC.

All times are GMT -5. The time now is 05:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.